Практическая работа Basic Spanning Tree Protocol (STP) Целью

advertisement
Практическая работа Basic Spanning Tree Protocol (STP)
Целью данной практической работы является анализ конфигурации Spanning Tree Protocol (STP) .
При выполнении будет использоваться Cisco Packet Tracer.
После выполнения практической работы будут получены знания по базовым командам для
диагностики STP на оборудования CISCO, а также закреплены навыки базовой конфигурации
коммутаторов 2-го уровня Cisco (Cisco Switches).
Используемая топология сети
План адресации
Анализ Spanning Tree Protocol ( STP )
1. Выполнить базовую конфигурацию для Sw1, Sw2, Sw3, Sw4
2. Выполнить конфигурацию сетевых параметров для Sw1, Sw2, Sw3, Sw4
3. Проанализировать конфигурацию STP
Ответить на вопросы:
1) По каким маршрутам будет выполнена передача между:
a. Sw1  Sw2
b. Sw2  Sw3
c. Sw3  Sw4
d. Sw4  Sw1
e. Sw1  Sw3
f. Sw4  Sw2
(ДО НАСТРОЙКИ).
1. Выполнить базовую конфигурацию Sw1.
Switch>enable
Switch#configure terminal
1.1 Установить имя хоста
Switch(config)#hostname Sw1
1.2 Отключить domain lookup
Sw1(config)#no ip domain lookup
1.3 Установить шифрованный пароль для Priveleged EXEC Mode
Sw1(config)#enable secret cisco
1.4 Включить logging synchronous (журналирование событий) и авторизацию по паролю для
console0 и vty 0-15
Sw1(config)#line console 0
Команда «line console 0» позволяет перейти к
конфигурированию консоли
Sw1(config-line)#logging synchronous
Sw1(config-line)#password cisco2
Sw1(config-line)#login
приглашение для аутентификации.
Sw1(config-line)#exit
Sw1(config)#line vty 0 15
(виртуальный терминал - virtual terminal line - нужны для
удаленного администрирования по протоколам
telnet, ssh).
Sw1(config-line)#logging synchronous
Sw1(config-line)#password cisco3
Sw1(config-line)#login
Sw1(config-line)#end
1.5 Сохранить промежуточную конфигурацию
Sw1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Sw2
Switch>enable
Switch#configure terminal
1.1 Установить имя хоста
Switch(config)#hostname Sw2
1.2 Отключить domain lookup
Sw2(config)#no ip domain lookup
1.3 Установить шифрованный пароль для Priveleged EXEC Mode
Sw2(config)#enable secret cisco
1.4 Включить logging synchronous и авторизацию по паролю для console0 и vty 0-15
Sw2(config)#line console 0
Sw2(config-line)#logging synchronous
Sw2(config-line)#password cisco2
Sw2(config-line)#login
Sw2(config-line)#exit
Sw2(config)#line vty 0 15
Sw2(config-line)#logging synchronous
Sw2(config-line)#password cisco3
Sw2(config-line)#login
Sw2(config-line)#end
1.5 Сохранить промежуточную конфигурацию
Sw2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Sw3
Switch>enable
Switch#configure terminal
1.1 Установить имя хоста
Switch(config)#hostname Sw3
1.2 Отключить domain lookup
Sw3(config)#no ip domain lookup
1.3 Установить шифрованный пароль для Priveleged EXEC Mode
Sw3(config)#enable secret cisco
1.4 Включить logging synchronous и авторизацию по паролю для console0 и vty 0-15
Sw3(config)#line console 0
Sw3(config-line)#logging synchronous
Sw3(config-line)#password cisco2
Sw3(config-line)#login
Sw3(config-line)#exit
Sw3(config)#line vty 0 15
Sw3(config-line)#logging synchronous
Sw3(config-line)#password cisco3
Sw3(config-line)#login
Sw3(config-line)#end
1.5 Сохранить промежуточную конфигурацию
Sw3#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Sw4
Switch>enable
Switch#configure terminal
1.1 Установить имя хоста
Switch(config)#hostname Sw4
1.2 Отключить domain lookup
Sw4(config)#no ip domain lookup
1.3 Установить шифрованный пароль для Priveleged EXEC Mode
Sw4(config)#enable secret cisco
1.4 Включить logging synchronous и авторизацию по паролю для console0 и vty 0-15
Sw4(config)#line console 0
Sw4(config-line)#logging synchronous
Sw4(config-line)#password cisco2
Sw4(config-line)#login
Sw4(config-line)#exit
Sw4(config)#line vty 0 15
Sw4(config-line)#logging synchronous
Sw4(config-line)#password cisco3
Sw4(config-line)#login
Sw4(config-line)#end
1.5 Сохранить промежуточную конфигурацию
Sw4#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
2. Выполнить конфигурацию сетевых параметров
Sw1
2.1 Отключить все порты
Sw1(config)#interface range FastEthernet 0/1-24
Sw1(config-if-range)#shutdown
Sw1(config-if-range)#exit
2.2. Включить порты с F0/1 по F0/3 в trunk mode
Sw1(config)#interface range FastEthernet 0/1-3
Sw1(config-if-range)#switchport mode trunk
Sw1(config-if-range)#no shutdown
2.3. Включить порты с F0/4 по F0/6 в access mode
Sw1(config)#interface range FastEthernet 0/4-6
Sw1(config-if-range)#switchport mode access
Sw1(config-if-range)#no shutdown
Sw1(config-if-range)#exit
2.4. Установить IP адреса на интерфейсе VLAN1
Sw1(config)#interface VLAN 1
Sw1(config-if)#ip address 192.168.10.1 255.255.255.0
Sw1(config-if)#no shutdown
Sw1(config-if)#end
2.5. Проверить правильность настройки командой ping
ping 192.168.10.1
2.6.Сохранить промежуточную конфигурацю
Sw1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Sw2
2.1 Отключить все порты
Sw2(config)#interface range FastEthernet 0/1-24
Sw2(config-if-range)#shutdown
Sw2(config-if-range)#exit
2.2. Включить порты с F0/1 по F0/3 в trunk mode
Sw2(config)#interface range FastEthernet 0/1-3
Sw2(config-if-range)#switchport mode trunk
Sw2(config-if-range)#no shutdown
2.3. Включить порты с F0/4 по F0/6 в access mode
Sw2(config)#interface range FastEthernet 0/4-6
Sw2(config-if-range)#switchport mode access
Sw2(config-if-range)#no shutdown
Sw2(config-if-range)#exit
2.4. Установить IP адреса на интерфейсе VLAN1
Sw2(config)#interface VLAN 1
Sw2(config-if)#ip address 192.168.10.2 255.255.255.0
Sw2(config-if)#no shutdown
Sw2(config-if)#end
2.5. Проверить правильность настройки командой ping
ping 192.168.10.2
2.6.Сохранить промежуточную конфигурацю
Sw2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Sw3
2.1 Отключить все порты
Sw3(config)#interface range FastEthernet 0/1-24
Sw3(config-if-range)#shutdown
Sw3(config-if-range)#exit
2.2. Включить порты с F0/1 по F0/3 в trunk mode
Sw3(config)#interface range FastEthernet 0/1-3
Sw3(config-if-range)#switchport mode trunk
Sw3(config-if-range)#no shutdown
2.3. Включить порты с F0/4 по F0/6 в access mode
Sw3(config)#interface range FastEthernet 0/4-6
Sw3(config-if-range)#switchport mode access
Sw3(config-if-range)#no shutdown
Sw3(config-if-range)#exit
2.4. Установить IP адреса на интерфейсе VLAN1
Sw3(config)#interface VLAN 1
Sw3(config-if)#ip address 192.168.10.3 255.255.255.0
Sw3(config-if)#no shutdown
Sw3(config-if)#end
2.5. Проверить правильность настройки командой ping
ping 192.168.10.3
2.6.Сохранить промежуточную конфигурацю
Sw3#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Sw4
2.1 Отключить все порты
Sw4(config)#interface range FastEthernet 0/1-24
Sw4(config-if-range)#shutdown
Sw4(config-if-range)#exit
2.2. Включить порты с F0/1 по F0/3 в trunk mode
Sw4(config)#interface range FastEthernet 0/1-3
Sw4(config-if-range)#switchport mode trunk
Sw4(config-if-range)#no shutdown
2.3. Включить порты с F0/4 по F0/6 в access mode
Sw4(config)#interface range FastEthernet 0/4-6
Sw4(config-if-range)#switchport mode access
Sw4(config-if-range)#no shutdown
Sw4(config-if-range)#exit
2.4. Установить IP адреса на интерфейсе VLAN1
Sw4(config)#interface VLAN 1
Sw4(config-if)#ip address 192.168.10.4 255.255.255.0
Sw4(config-if)#no shutdown
Sw4(config-if)#end
2.5. Проверить правильность настройки командой ping
ping 192.168.10.4
2.6.Сохранить промежуточную конфигурацю
Sw4#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
3. Проанализировать конфигурацию STP
Sw4
Sw4#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 0001.9791.82DC
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 0001.9791.82DC
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface
Role Sts Cost
Prio.Nbr Type
---------------- ---- --- --------- -------- -------------------------------Fa0/1
Desg FWD 19
128.1 P2p
Fa0/2
Desg FWD 19
128.2 P2p
Fa0/3
Desg FWD 19
128.3 P2p
Fa0/4
Desg FWD 19
128.4 P2p
Fa0/5
Desg FWD 19
128.5 P2p
Fa0/6
Desg FWD 19
128.6 P2p
Sw1
Sw1#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 0001.9791.82DC
Cost 19
Port 1(FastEthernet0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 000A.413B.C454
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface
Role Sts Cost
Prio.Nbr Type
---------------- ---- --- --------- -------- -------------------------------Fa0/3
Desg FWD 19
128.3 P2p
Fa0/4
Desg FWD 19
128.4 P2p
Fa0/5
Desg FWD 19
128.5 P2p
Fa0/6
Desg FWD 19
128.6 P2p
Fa0/1
Root FWD 19
128.1 P2p
Fa0/2
Desg FWD 19
128.2 P2p
Sw3
Sw3#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 0001.9791.82DC
Cost 19
Port 2(FastEthernet0/2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 0060.702B.4E59
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface
Role Sts Cost
Prio.Nbr Type
---------------- ---- --- --------- -------- -------------------------------Fa0/1
Altn BLK 19
128.1 P2p
Fa0/2
Root FWD 19
128.2 P2p
Fa0/3
Altn BLK 19
128.3 P2p
Fa0/4
Desg FWD 19
128.4 P2p
Fa0/5
Desg FWD 19
128.5 P2p
Fa0/6
Desg FWD 19
128.6 P2p
Sw2
Sw2#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 0001.9791.82DC
Cost 19
Port 3(FastEthernet0/3)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 0030.F250.433D
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20
Interface
Role Sts Cost
Prio.Nbr Type
---------------- ---- --- --------- -------- -------------------------------Fa0/1
Altn BLK 19
128.1 P2p
Fa0/2
Desg FWD 19
128.2 P2p
Fa0/3
Root FWD 19
128.3 P2p
Fa0/4
Desg FWD 19
128.4 P2p
Fa0/5
Desg FWD 19
128.5 P2p
Fa0/6
Desg FWD 19
128.6 P2p
Ответьте на вопросы:
1) К чему приведёт петля в сети? Свой ответ объясните.
2) Какой протокол используется для борьбы с петлями?
3) Как работает протокол связующего дерева?
Практическая работа Basic Spanning Tree Protocol (STP) – часть №2.
№1. Собрать в Cisco Packet Tracer следующую сеть:
Зеленым кружком показывается активный линк, соответственно оранжевым — неактивный.
Как видно, stp уже сработал автоматически и отключил интерфейс на Switch1.
Cisco Packet Tracer является лишь средой моделирования, а не операционной системой
реалього оборудования, поэтому имеет ограниченный набор функций для конфигурации этого
протокола.
Все настройки находятся в меню интерпретатора spanning-tree. Проверить его работу можно
например разорвав линк между Switch2 и Switch3. Через некоторое время поднимется линк на
Switch1. STP выбирает наилучший путь и по скорости соединения. Проверим. Установим
скорость 10 мбит межу Switch0 и Switch2.
На Switch0
Switch#en
Switch#conf t
Switch(config)#in fa0/3
Switch(config-if)#speed 10
Switch(config-if)#exit
Switch(config)#exit
На Switch2:
Switch#conf t
Switch(config)#in fa0/1
Switch(config-if)#speed 10
Switch(config-if)#exit
Switch(config)#exit
После чего сетевой интерфейс на Switch0 отключится, а на Switch1 включится. STP сработал.
Скачать